Welcome Guest. Sign in or Signup

5 Answers

Rich text ads not displaying

Asked by: Vlad 499 views User Questions

Hi Mike,

please help us to settle down the following issue we encounter.

We set up a rich text media with a content that looks similar to the one below:

Some text goes here link text some text here.

For that media we have a campaign, which is assigned into a zone.

We used the code wizard to generate the code and put it on a page, but ad didn’t show up. When we used directly the URL from code wizard’s code (http://adforce.advertserve.com/servlet/view/text/javascript/zone?zid=53), we got the following error:

/*
An error or condition occurred that prevented a media from being displayed: see error_log for more information
*/

We tried to generate code for campaign and media and it worked. However, we would like to be able to use zone’s code for reporting purposes and ability to be more flexible when changing ad settings.

Regards, Vlad.

5 Answers



  1. renegade_mike on Sep 10, 2007

    My guess is that the campaign has some type of target(s) set on it that is invalidating the campaign or doesn’t apply to you, so you can’t see it.

    To find out for sure, go to Settings > Expert > Logging and change the Logging Level to Warning. Try to view the zone again and then set the logging level back to critical. If you then go to Maintenance > Diagnostics > Logs and view the error_log for today, it should display a message with more detail about why the campaign couldn’t be displayed. Please post that error message here and I’ll let you know what’s wrong.

    0 Votes Thumb up 0 Votes Thumb down 0 Votes



  2. Vlad on Sep 10, 2007

    renegademike;2253 wrote: To find out for sure, go to Settings > Expert > Logging and change the Logging Level to Warning.

    Mike, admin has no access to that page :(
    Any idea why?

    By the way, we managed to set up that campaign by remaking media, campaign and zone. But still we would like to know the cause of that error, so we don’t face it in future.

    0 Votes Thumb up 0 Votes Thumb down 0 Votes



  3. renegade_mike on Sep 10, 2007

    Sorry, on AdvertSERVE we don’t allow you to change the logging level.

    I did it though and the reason the text ad isn’t being displayed is the campaign start date is set to October 1, 2007.

    The reason the campaign/media were displayed when invoked directly is targeting is only evaluated when invoking a zone.

    0 Votes Thumb up 0 Votes Thumb down 0 Votes



  4. Vlad on Sep 10, 2007

    Thanks for the quick reply.

    renegademike;2256 wrote: The reason the campaign/media were displayed when invoked directly is targeting is only evaluated when invoking a zone.

    Does this mean that delivery cappings will also be evaluated only when invoking a zone?

    0 Votes Thumb up 0 Votes Thumb down 0 Votes



  5. renegade_mike on Sep 10, 2007

    Yes, that is the case. When you request a media or campaign directly, it is essentially treated as a request for static content.

    0 Votes Thumb up 0 Votes Thumb down 0 Votes